tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу,выводящую
Составьте программу,выводящую на экран все трехзначные натуральные числа, делящиеся на 17 без остатка
kristinamoroz1
2 20.07.2019 00:10
7
Ответы
hehdsfg1
03.10.2020 08:25
1)
var k:integer;
begin
for k:=100 to 999 do
if k mod 17 = 0 then writeln(k);
end.
2)
var k: integer;
begin
k:=100;
while k mod 17 <> 0 do inc(k);
while k<999 do
begin
writeln(k);
k:=k+17;
end;
end.
Решение:
102
119
136
153
...
952
969
986
ПОКАЗАТЬ ОТВЕТЫ
mschibarova201
03.10.2020 08:25
// PascalABC.NET 3.1, сборка 1174 от 22.02.2016
begin
Range(100,999).Where(n->(n mod 17=0)).Print
end.
Результат выполнения программы:
102 119 136 153 170 187 204 221 238 255 272 289 306 323 340 357 374 391 408 425 442 459 476 493 510 527 544 561 578 595 612 629 646 663 680 697 714 731 748 765 782 799 816 833 850 867 884 901 918 935 952 969 986
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
nimblefish
07.05.2020 10:41
То такое спрайт? зачем нужна сцена? что такое скрипт и где его писать? как запустить и остановить анимацию?...
khursin03
07.05.2020 10:40
Используя словари, выясните, как переводятся на русский язык слова multum и medium, от которых произошло слово «мультимедиа». Из какого языка взяты эти два слова...
Pingvinchikc
07.05.2020 10:39
В ячейке электронной таблицы С3 записана формула =В5+$D$3-E$3. Какой вид приобретает формула если ячейка С3 скопировала в ячейку В...
swetammm2018
07.05.2020 10:38
Из 103 приехавших туристов 71 знали испанский язык и 84 знали английский язык. 8 человек не знали ни испанского, ни английского. Сколько туристов знали оба этих языка?...
Masya1415
07.05.2020 10:38
A =10 b= 3 a = a // 2 % 3 print(a,b)...
Irish23
07.05.2020 10:37
Рассмотрите решение задачи. Сколько раз выполнится цикл,если n=5,a=3. И,что будет выведено на экран,если n=5,a=2 Тема:Программирование циклических алгоритмов program...
andreytolstik
07.05.2020 10:37
Чему будет равно значение целой переменной a после выполнения этого фрагмента программы? a:=2; for i:=0 to 4 do begin a:=a+i; end; Чему будет равно значение целой...
Фейдииик
07.05.2020 10:36
БАЮ МНОГО ! НЖУНО РЕШИТЬ ЗАДАЧИ, ПО ТАКОЙ ФОРМЕ: НАДО;НАЙТИ;РЕШЕНИЕ Считая, что один символ кодируется 16 битами, подсчитать количество информации, содержащееся в...
nicsiberia
07.05.2020 10:36
Кто-нибудь у нас сор по информатике сделайте первое и второе задание это очень-очень...
caxopo4ek
07.05.2020 10:36
В какой точке окажется исполнитель Чертежник? алг нач поднять перо сместиться в точку (1,2) опустить перо нц 3 раз сместиться на вектор(1,2) сместиться на вектор...
Популярные вопросы
Люди ,что за еле видимаая полоска от пупка к лет не удааляйте...
1
Нужно сделать морфологический разбор слов со звездочкой...
3
Lim n infty(n\root(3)(7n) -\root(4)(81n^(8)-1))/((n+4\sqrt((n^(2)-5))...
1
Определить равнодействующую для скользящей системы f1-30кн f2-10кн...
2
Выражение a)–3a в пятой степени * 4ab в шестой степени...
3
Предположи предложение: 《земные теории,божества стихий,в отличие...
2
Раскройте все скобки и переведите подобные члены 13+2(7-х)=...
2
5. найдите ошибки в употреблении имен числительных в предложениях...
1
Реакция растворения примеси меди в разбавленной hno3 при аффинаже...
1
15 ! какими качествами обладает мороз? почему он одновремено воевода...
1
var k:integer;
begin
for k:=100 to 999 do
if k mod 17 = 0 then writeln(k);
end.
2)
var k: integer;
begin
k:=100;
while k mod 17 <> 0 do inc(k);
while k<999 do
begin
writeln(k);
k:=k+17;
end;
end.
Решение:
102
119
136
153
...
952
969
986
begin
Range(100,999).Where(n->(n mod 17=0)).Print
end.
Результат выполнения программы:
102 119 136 153 170 187 204 221 238 255 272 289 306 323 340 357 374 391 408 425 442 459 476 493 510 527 544 561 578 595 612 629 646 663 680 697 714 731 748 765 782 799 816 833 850 867 884 901 918 935 952 969 986