Составьте программу вывода на экран всех простых чисел, не превосходящих заданного n. простым называется натуральное число больше единицы, имеющее только два делителя: единицу и само это число

Bogdasha30060t Bogdasha30060t    1   01.09.2019 13:50    4

Ответы
Про228лирс Про228лирс  06.10.2020 09:52
#Python 3.5.2
a = []
n = int(input('Введите n: '))
for i in range (n+1): a.append(0);
for i in range (2, n+1):
    if a[i]==0:
        print (i, end='; ')
        j = 2*i
        while j<=n:
            a[j] = 1
            j+=i
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика