Составьте программу вывода числа делителей натурального числа м в паскале abc

dyadyan dyadyan    2   31.07.2019 09:00    1

Ответы
samojlenko15 samojlenko15  28.09.2020 13:59
Var m,d,kol:uint64;
begin
read(m);
for d:=1 to m do begin
   if (m mod d)=0 then inc(kol);
   end;
write(kol);
end. Это программа для делителей от 1 до m.

var m,d,kol:uint64;beginread(m);for d:=2 to m-1 do begin   if (m mod d)=0 then inc(kol);   end;write(kol);end. Эта программа для делителей от 2 до m-1.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика