Составьте программу, вычисляющую для двух дробей a/b и c/d (a,b,c,d - натуральные числа): деление умножение сложение. результат представить в виде простых несократимых дробей в виде функции. pascal

Misha01923 Misha01923    2   07.06.2019 14:10    1

Ответы
MastruevaNasty MastruevaNasty  01.10.2020 21:30
Как-то так)

var a,b,c,d,e,f:integer;
function nod(m,n:integer):integer;
begin
while m<>n do
if m>n then m:=m-n
       else n:=n-m;
nod:=m
end;
begin
write('введите числитель1, знаменатель1, числитель2, знаменатель2');
readln(a,b,c,d);
e:=a*d+b*c;
f:=b*d;
 if f=0 then write('на 0 делить нельзя')
else
if e=0 then writeln('сложение =  ',e) 
      else begin
       e:=e div nod(abs(e),f); 
       f:=f div nod(abs(e),f); 
       writeln('сложение =  ',e,'\',f); 
       end;
e:=a*c;
f:=b*d;
 if f=0 then write('на 0 делить нельзя')
else
if e=0 then writeln('умножение = ',e)
else begin
 e:=e div nod(abs(e),f);
       f:=f div nod(abs(e),f);
       writeln('умножение =  ',e,'\',f);
         end;
e:=a*d;
f:=b*c;
if f=0 then write('на 0 делить нельзя')
else
         if e=0 then writeln('деление=  ',e)
else begin e:=e div nod(abs(e),f);
       f:=f div nod(abs(e),f);
       writeln('деление =  ',e,'\',f); 
        end; 
     end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика