tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу вычисления
Составьте программу вычисления выражения (разными применяя каждый из операторов while,repeat,for) a^p, где p - целое число. pascal / надо.
ROLFRUTIN
2 17.09.2019 04:10
6
Ответы
dilyahashimova
04.08.2020 10:00
1)Это с
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1; i:=0;
while i<p do
begin
c:=c * a;
inc(i);
end;
writeln(c);
readln;
end.
2) Это с
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1; i:=0;
repeat
c:=c * a;
inc(i);
until i=p;
writeln(c);
readln;
end.
3) Это с
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1;
for i:=1 to p do
c:=c * a;
writeln(c);
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
aArisha2772
14.03.2019 18:08
Напишите все команды которые используются тут. var s,k: integer; begin s : = 3; for k : = 0 to 9 do begin if k mod 2=0 then s : = s + 3 ; writeln(k); end; writeln(s); end....
lizench
27.04.2020 14:48
Термин информатизация общества означает: а) Увлечение количества избыточной информации в обществе. б) Увлечение роли средств массовой информация. в) Эффективное истюль зование...
Хитрая0Лиса0
09.07.2019 11:00
Найти кол-во чисел, кратных 8 и оканчивающихся на 6, из диапозона от 10 до 200. 50...
султа65
27.05.2019 09:40
Составьте рассказ о первых колониях и их жителях....
Зухриддин11
27.05.2019 09:40
Запишите уравнение реакций обмена котрых можно получить хлорид железа (ii) двумя и рассмотрите их в свете тэд. мне...
zozoshcka17
27.05.2019 09:40
Маса бочёнка вместе с мёдом 20 кг а без мёда 2 кг . во сколько раз масса мёда в этом бочёнке больше массы самого бочёнка запиши что, узнаеш первым действием закончи ришение...
voinabeskonechnosti
27.05.2019 09:40
Напишите стишок на тему мы жизнелюбивый класс...
myhaylonotochk
27.05.2019 09:40
Морфологический разбор слова. слова: печальным, простыня...
топфифа2
27.05.2019 09:40
Как влияет скорость движения молекул веществ на протекание диффузии в этих веществах...
mashaleonteva2
27.05.2019 09:40
Подобрать примеры из лит. чт. ответсвеное повидение! зарание !...
Популярные вопросы
Почему при купании нужно соблюдать осторожности...
1
Запишите слова так сначала проверочное слово а затем проверяемое вещи...
2
Для умных.на дереве росли всего 10 яблок.петя взял из них вмего 4.а у...
2
Вслучае опасности еж быстро сворачивается в клубок. но некоторые хищники...
1
Сократите дробь на наибольший общий делитель ее ччислителя изнаменателя...
3
Можно ли охладить комнату с открытым дверцем холодильника подключенной...
3
Igo shopping several times per week. nowadays there are so many types...
3
Какое можно получить слово из буквы и р а п д м и а к...
1
Выберите из списка небесных объектов названия звёзд. 1)алькор 2)близнецы...
3
Особенности покрытосеменного растения береза...
3
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1; i:=0;
while i<p do
begin
c:=c * a;
inc(i);
end;
writeln(c);
readln;
end.
2) Это с
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1; i:=0;
repeat
c:=c * a;
inc(i);
until i=p;
writeln(c);
readln;
end.
3) Это с
var a,p,i,c:integer;
begin
readln(a);
readln(p);
c:=1;
for i:=1 to p do
c:=c * a;
writeln(c);
readln;
end.