Составьте программу вычисления в массиве а(10) заполненном случайными числами из интервала (-5,10) количества отрицательных элементов

конфетка03031 конфетка03031    1   15.08.2019 18:20    2

Ответы
mrarmen1999mailru mrarmen1999mailru  04.10.2020 21:30
Полагаю, Pascal ABC.

//Для Pascal ABC.Net:
Var a:array[1..10] of longint;n,i,k:longint;
Begin
readln(n); //Читаем количество элементов в массиве
for i:=1 to n do
begin
read(a[i]); //Читаем каждый элемент в массиве
if (a[i]<0) then k+=1; //Увеличиваем счётчик k на 1, если элемент меньше нуля
end;
writeln(k); //Выводим счётчик k
End.

//Для Pascal ABC:
Var a:array[1..10] of integer;n,i,k:integer; //Простой Паскаль не поддерживает longint
Begin
readln(n); 
for i:=1 to n do
begin
read(a[i]); 
if (a[i]<0) then k:=k+1; //Отличие в том, что здесь нельзя просто увеличить с только с :=k+1
end;
writeln(k); //Выводим счётчик k
End.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика