Составьте программу вычисления суммы повторяющихся элементов одномерного массива. (паскаль)

gosharybchinckyi gosharybchinckyi    2   29.08.2019 22:00    5

Ответы
betmurzaev2015 betmurzaev2015  26.08.2020 12:09
// PascalABC.NET 3.2, сборка 1417 от 28.03.2017
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(ReadInteger('n='),-20,20); a.Println;
  Writeln('Sдубл=',a.GroupBy(c->c).Select(c->(c.Key,c.Count))
      .Where(c->c[1]>1).Select(c->c[0]*c[1]).Sum)
end.

Пример
n= 15
1 2 -10 18 8 -18 -8 -6 -11 -7 -10 -11 3 2 2
Sдубл=-36
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика