Составьте программу вычисления суммы элементов массива от второго положительного и до конца я составил такой код, но вот только сумму он определяет не так. есть какие-то идеи? program qq; const n=10; var a: array[1..n] of integer; i,p,j,sum: integer; begin for i: =1 to n do begin a[i]: =random(20)-10; write(a[i],' '); end; j: =0; for i: =1 to n do begin if a[i]> 0 then j: =j+1; if j = 2 then p: =i; end; for i: =p+1 to n do sum: =sum+a[i]; writeln(); writeln('сумма элементов от второго положительного: ',sum); end.

dadfxhg dadfxhg    1   12.07.2019 11:40    6

Ответы
Roman22020 Roman22020  18.09.2020 11:49
У вас что-то слишком сложная структура для такой задачи.
Предлагаю вариант покороче, скрин и исходник в приложении.
Складывает все числа (положительные и отрицательные) начиная со второго положительного включительно, то есть второй элемент так же будет задействован.

Составьте программу вычисления суммы элементов массива от второго положительного и до конца я состав
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика