Составьте программу вычисления площади кольца с внутренним радиусом r1 и внешним радиусом r2.значения r1 и r2 введите с клавиатуры

ElleFox ElleFox    2   31.03.2019 07:00    6

Ответы
kcasimova2018 kcasimova2018  27.05.2020 21:08

Если твое кольцо есть фигура Тор, то это внешний и внутренний радиусы. (Внешний больше). Тогда код вот такой:

 

uses crt;
var
r1,r2: real;
begin
read(r1,r2);
writeln(pi*(r1*r1-r2*r2):0:3);
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика