Составьте программу вычисления куба суммы всех четных чисел от 2 до 100 и как она работает

Zan22 Zan22    2   04.10.2019 20:30    5

Ответы
соыварщ соыварщ  21.08.2020 21:46
program task31102063; var  Sum: real; begin  for var i := 2 to 100 do    if i mod 2 = 0 then      Sum := Sum + Power(i, 3);  Writeln(Sum); end.

Принцип очень прост: инициализируем цикл с итератором, равным 2, до 100. Далее проверяем, является ли итератор (то есть число) чётным - для этого просто возьмем целую часть от деления на 2. Если равна нулю, то число чётное, если нет - то это остаток.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика