Составьте программу вычисления функции y=sinx2^n используйте подпрограмму,функцию для ее вычисления

lynnikova05 lynnikova05    3   14.08.2019 17:20    3

Ответы
anastasiyachevh anastasiyachevh  04.10.2020 19:14
Var x,y:real; n:integer;
function f(x:real;n:integer):real;
var i,st:integer;
begin
st:=1;
for i:=1 to n do st:=st*2;
f:=sin(x)*st;
end;
begin
writeln('x, n:');
readln(x,n);
y:=f(x,n);
writeln('x = ',x,' y = ',y);
end.

Пример:
x, n:
2 5
x = 2 y = 29.0975176584218
ПОКАЗАТЬ ОТВЕТЫ
zaira0 zaira0  04.10.2020 19:14
Program sinus;
var x,y:real;
begin
writeln('введите число');
readln(x);
y:=sin(x)*2*2;
writeln(y);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика