Составьте программу в результате выполнения которой выясняется входят ли четные цифры в запись данного трехзначного числа. для паскаля

lugmar3 lugmar3    2   02.08.2019 21:20    2

Ответы
dimatitov1428dimasik dimatitov1428dimasik  30.09.2020 03:54
Var a,a1,a2,a3:integer;
begin
write('a = ');
readln(a);
a1:=a div 100;
a2:=a div 10 mod 10;
a3:=a mod 10;
if (a1 mod 2 = 0)or(a2 mod 2 = 0)or(a3 mod 2 = 0)
 then writeln('В числе есть четные цифры')
 else writeln('В числе нет четных цифр');
end.

Пример:
a = 519
В числе нет четных цифр
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика