Составьте программу в паскале заполнить массив а пятью произвольными целыми числами. изменить каждый элемент массива так, чтобы он был умножен на свой порядковый номер. исходный и полученный массив вывести на экран. пример: исходный массив: 2 6 8 9 12 полученный массив: 2 12 24 36 60

slavaapakinp00lrn slavaapakinp00lrn    2   20.08.2019 18:40    5

Ответы
alexguzz55 alexguzz55  05.10.2020 07:49
Для случайных чисел:

var
   a: array[1..5] of integer;
   i: integer;
begin
   randomize;
   for i:=1 to 5 do
      a[i] := random(100);
   for i:=1 to 5 do
      write(a[i], ' ');
   writeln;
   for i:=1 to 5 do
      a[i] := a[i] * i;
   for i:=1 to 5 do
      write(a[i], ' ');
end.

Для ручного заполнения:

var
   a: array[1..5] of integer;
   i: integer;
begin
   for i:=1 to 5 do
      readln(a[i]);
   for i:=1 to 5 do
      write(a[i], ' ');
   writeln;
   for i:=1 to 5 do
      a[i] := a[i] * i;
   for i:=1 to 5 do
      write(a[i], ' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика