Составьте программу в паскаль для вычисления: найти радиус окружности, описанной около правильного n-угольника со стороной а

samsamokruxa samsamokruxa    3   07.10.2019 04:30    2

Ответы
seal2004 seal2004  10.10.2020 00:56

var

   n : integer; // количество сторон (углов)

   a : integer; // длина стороны

   

begin

   write('введите количество сторон n= ');

   readln(n);

   write('введите длину стороны a= ');

   readln(a);

   writeln('радиус описанной окружности R=', a/2*(sin(pi/n)));

end.

не забываем что паскаль считает в радианах и формула расчета соответственная...

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика