Составьте программу в pascal: компьютер задаёт случайное двухзначное число х, например 39; компьютер задаёт случайное однозначное число у, например 8; необходимо получить новое трехзначное число z, а именно 389т.е.число у вписать в середину х​

Ксюша99009 Ксюша99009    2   12.04.2019 17:54    2

Ответы
AnnaMillerNikitina AnnaMillerNikitina  29.05.2020 09:09

var x,y,z:integer;

begin

   randomize;

   x:=1;

   repeat x:=random(100) until x>9;

   y:=random(10);

   z:=(x div 10)*100+y*10+(x mod 10);

   writeln('x=', x);

   writeln('y=', y);

   writeln('z=', z);

end.

ПОКАЗАТЬ ОТВЕТЫ
rsavka59 rsavka59  29.05.2020 09:09

program raf105;

var x,y,z:integer;

begin

x:=random(10,99);

writeln('Компьютер выбрал число ',x);

y:=random(1,9);

writeln('Компьютер выбрал число ',y);

z:= x mod 10;

x:= (x-z)*10;

z:= (x+z)+y*10;

writeln('Компьютер переместил второе число в середину первого. Результат: ',z);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика