Составьте программу решения квадратного уравнения, если заданы его коэффициенты в условном операторе (

svetbuxzp51 svetbuxzp51    1   27.08.2019 08:50    5

Ответы
katyakot56806 katyakot56806  05.10.2020 22:28
Program kvadrurav;
var
a:integer;
b:integer;
c:integer;
d:integer;
begin
Writeln('введите число а');
Readln(a);
Writeln('введите число b')
;Readln(b);
Writeln('введите число c');
Readln(c);
d:=b*b-(4*a*c);
if d>0 then  Writeln('x1=',(-b-Sqrt(D))/(2*a),' ','x2=',((-b+Sqrt(D))/(2*a))) ;
 if d=0 then          
Writeln('x1=',-b/(2*a))     
else     
Writeln('нет корней');
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика