Составьте программу разложения данного натурального числа на простые множители. например, 200 = 2^3 × 5^2 × это умножить

DsBrend11 DsBrend11    3   14.06.2019 18:15    1

Ответы
Даша12Няшка Даша12Няшка  02.10.2020 01:59

var

 n, i, k: integer;

begin

 repeat

   write('Введите натуральное число n= ');

   read(n);

 until n > 0;

 if n = 1 then writeln('Невозможно разложить на произведение простых множителей.')

 else

 begin

   write(n, '=');

   i := 2;

   while i <= n do

   begin

     k := 0;

     while n mod i = 0 do

     begin

       k := k + 1;

       n := n div i;

     end;

     if i < n then

     begin

       if k = 1 then write(i, '*')

       else if k > 1 then write(i, '^', k, '*');

     end

     else

     begin

       if k = 1 then write(i)

       else if k > 1 then write(i, '^', k);

     end;

     i := i + 1;

   end;

 end;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика