Составьте программу, проверяющую, лежит ли точка с заданными координатами вне круга с радиусом r и началом в точке o(a,b) хотя бы примерно

Marshall123 Marshall123    3   18.03.2019 15:50    2

Ответы
Iliawer Iliawer  26.05.2020 00:14

var

 x, y, R, Oa, Ob: real;

 

begin

  writeln('Введите радиус окружности R');

  readln(R);

  writeln('Введите координаты центра окружности');

  readln(Oa, Ob);

  writeln('Введите координаты точки');

  readln(x, y);

  if (x > (Oa - R)) and (x < (Oa + R)) and (y  > (Ob - R)) and (y < (Ob + R)) then

    writeln('Точка с заданными координатами лежит внутри круга')

  else

    writeln('Точка с заданными координатами лежит вне круга');

end. 

Если все правильно, отметь решение как лучшее)

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика