Составьте программу произведения первой и третьей и суммы второй и четвертой цифры четырехзначного числа (паскаль)

Vicus44ea Vicus44ea    2   25.06.2019 03:10    5

Ответы
nasty2204 nasty2204  20.07.2020 12:53
Program zadacha;
var
a,p,s:integer;
begin
writeln('Введите четырехзначное число');
readln(a);
p:=(a div 1000)*(a mod 100 div 10);
s:=(a div 100 mod 10)+(a mod 10);
writeln('Произведение первой и третьей =',p);
writeln('Сумма второй и четвертой = ',s)
end.
ПОКАЗАТЬ ОТВЕТЫ
СветланаУсова СветланаУсова  20.07.2020 12:53
Program programma;
var a,b,c,d,e,p,s: integer;
begin
writeln ('Введите четырехзначное число');
readln (a);
b:=a div 1000;
c:=a div 100;
c:=c mod 10;
d:=a mod 100;
d:=d div 10;
e:=a mod 10;
p:=b*d;
s:=c+e;
writeln ('Произведение первой и третьей цифры равно ',p,', сумма второй и четвертой цифры равна ',s);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика