Составьте программу, позволяющую определить, являются ли числа a,b,c, пифагоровыми тройками.указанные числа a,b,c, являются пифагоровыми тройками, если квадрат одного из чисел равен сумме квадратов двух других.

GenGis GenGis    3   24.06.2019 03:30    3

Ответы
arrrtem arrrtem  19.07.2020 19:24
Program pifThi;
var
 a,b,c:integer;
begin
 readln(a,b,c);
 if (sqr(a)=sqr(c)+sqr(b)) or 
    (sqr(b)=sqr(a)+sqr(c)) or
    (sqr(c)=sqr(a)+sqr(b)) then write('Yes!')
 else write('No!'); readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика