tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу перевода
Составьте программу перевода двоичной записи натуральных чисел в десятичную.(в pascal abc)
ostlena50
2 21.07.2019 16:50
3
Ответы
Savasansa
19.08.2020 15:13
Var i: integer;
n,k: int64;
s: string;
begin
write('двоичное число: '); readln(s);
k:=1; n:=0;
for i:=length(s) downto 1 do
begin
n:=n+(ord(s[i])-48)*k;
k:=k*2;
end;
writeln('десятичное число: ',n);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
AyanaHaverfords
06.05.2020 14:41
Компьютерлік ойынға құрылатын құжаттама дегеніміз не...
ruzanayvazyan
06.05.2020 14:40
Текстовый процессор Word можно организовать автоматический сбор заголовка?...
айдана152
06.05.2020 14:40
Для швейної компанії розробіть проект із графічним інтерфейсом Залишок, за до якого користувач планового відділу буде визначати площу тканини, яка залишиться після того, як...
ElenaBkv
08.10.2019 10:52
Практическая работа no 3 кодирование числовой информации в компьютере. получение дополнительного кода числа» цель: познакомить с кодированием числовой информации в компьютере....
fdimon
08.10.2019 10:50
Составьте к этой программе блок схему ...
Sasho2325
08.10.2019 10:47
Информатика решите скорей 30...
llvoronall
08.10.2019 12:10
Запиши ip-адрес, если известно, что ip подсети: 111.78.0.0 ip хоста: 0.0.182.203...
sts23
08.10.2019 12:10
1.чему будет равна переменная «c» после выполнения этой программы: a : = 28; b : = 7; b : = a div b + b; c : = a mod b + a; 2. чему будет равна переменная «c» после выполнения...
SensRow
08.10.2019 12:20
1. как называется класс, который на примере ниже? type tform1 = class(tform) memo1: tmemo; button1: tbutton; procedure button1click(sender: tobject); . . end; 2. что обозначает...
Marfushka77
08.10.2019 12:20
Решите 1. максимальная скорость передачи данных в локальной сети 100 мбит/с. сколько страниц текста можно передать за 1 сек, если 1 страница текста содержит 50 строк и на каждой...
Популярные вопросы
Льстивость, притворство недоросля...
3
Вопросы: 1. Какого строение глаза? 2. Одинаково ли развиты органы зрения...
3
13. Визначте місце у клітині, де відбувається біосинтез: а) у мітохондріях;...
1
Почему Мова язык на украинском?...
2
При каких приемов народ подчиняли воле диктатора?...
3
Как называются знаки, выделенные на рисунке красным цветом. Что это означает?...
1
, не понимаю геометрию вообще, а задание надо сделать...
1
3. На месте пропуска поставьте нужный знак препинания в конце предложения....
3
Доказать, что a/b + b/a≥2, если ab 0...
1
Які інструменти редактора Photoshop можна викоростатися для для управління...
3
n,k: int64;
s: string;
begin
write('двоичное число: '); readln(s);
k:=1; n:=0;
for i:=length(s) downto 1 do
begin
n:=n+(ord(s[i])-48)*k;
k:=k*2;
end;
writeln('десятичное число: ',n);
end.