Составте программу (паскале абц) и блок схему даны два действительных положительных числа x и y. тригонометрические действия над числами пронумерованы (1 - sin, 2 - cos, 3 - tg, 4 - ctg). составить программу, которая по введенному номеру n выполняет то или иное действие над числами x и y.

лера2083 лера2083    1   09.06.2019 05:00    3

Ответы
Xro8 Xro8  08.07.2020 01:44
var
  n: integer;
  x, y: real;

begin
  readln(n, x, y);
  case n of
    1: writeln('sin(', x, ') = ', sin(x), #13, 'sin(', y, ') = ', sin(y));
    2: writeln('cos(', x, ') = ', cos(x), #13, 'cos(', y, ') = ', cos(y));
    3: writeln('tg(', x, ') = ', tan(x), #13, 'tg(', y, ') = ', tan(y));
    4: writeln('ctg(', x, ') = ', 1 / tan(x), #13, 'ctg(', y, ') = ', 1 / tan(y));
    else
      writeln('Null');
  end;
end.
Составте программу (паскале абц) и блок схему даны два действительных положительных числа x и y. три
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика