Составьте программу (паскаль) для решения :

в игре " лото" из мешка случайным образом выбираются бочонки , на каждом из которых написано число от 1 до 50. напишите программу, которая выводит наугад первые 3 выигрышных номера.
​

TheTanyaStar2k TheTanyaStar2k    1   21.10.2019 11:49    9

Ответы
madamnowiczkai madamnowiczkai  10.10.2020 08:21

program Loto;

var

 L: array [1..50] of Integer;

 a: array [1..3] of Integer;

 i, j, n: Integer;

 b: Boolean;

begin

 for i := Low (L) to High (L) do

   L [i] := i;

 Randomize;

 for i := 1 to 3 do begin

   repeat

     n := Random (51) + 1;

   until L[n] <> 0;

   a [i] := L [n];

   L [n] := 0;

 end;

 for i := 1 to 3 do

   Write (a [i], ' ');

 ReadLn;

end

Объяснение:

сделана проверка чтобы 3 числа не совпадали друг с другом

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика