tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу(паскаль)
Составьте программу(паскаль) для определения количества цифр в записи произвольного натурального числа. сейчас проходим while, судя по всему его и надо использовать.
alena0303
3 25.08.2019 17:30
1
Ответы
ffplfref
05.10.2020 19:16
Var n,p,k:integer;
begin
readln (n);
p:=n;
while p<> 0 do begin
k:=k+1;
p:=p div 10;
end;
writeln ('k=',k);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
max78789867
10.09.2020 12:54
2. Что такое интернет-зависимость?...
lassdeavs
10.09.2020 12:54
Мониторлардың стандарты туралы мәлімет...
фиксоня
10.09.2020 12:53
Написать программу на питон! У Даши есть два брата — Даня и Дима. А еще у нее есть n конфет, вкус i-й конфеты можно оценить как ai (чем больше число, тем конфета вкуснее, причем...
Mini03
10.09.2020 12:53
Изображение 20 на 20 точек, использует 10 цветов. Определите количество информации в этом изображении с этим заданием...
f2a5p4
13.09.2020 12:25
НА ЯЗЫКЕ ПАЙТОН Integer8◦ Дано двузначное число. Вывести число, полученное при переста-новке цифр исходного числа.Integer9◦. Дано трехзначное число. Используя одну операцию деления...
Pilulkin112
16.09.2019 06:40
Определить информационный объем текста состоящего из 300 символов записанного с алфавита содержащего 40 символов....
10121945
21.04.2020 07:57
Для чего используется предворительный...
supersattarova
17.08.2019 05:30
1)12x-35+7x=98 2)25 (x+1)-16= 59 3)13 (x+6)-72=123...
HsbHbaj
17.08.2019 05:30
Какой обьём водяного пара вделиться при сжигании 50 г водорода...
vitalicc
17.08.2019 05:30
Основы каких слов одинаковые по строению мебель и тумбочка.пылесос и корабль.избушка и старенький...
Популярные вопросы
Укати была ленточка длиной 24 см. у маши была ленточка длиной 28 см. катя...
1
Довжина кожноі сторони трикутника становить 12 см...
3
Значення словосполучення замилювати очи, за тридев ять земель, кури не клюють,...
2
Выпишите номера признаков, характерных для каждого класса животных. класс:...
2
Ви побачили зруйноване сховище отрутохімікаті. у чому полягає загроза вашій...
3
Как планктонные водоросли удерживаются в освещённом слое воды?...
3
При горении магния образовалось 2,0 г оксида магния. определите: а) массу...
2
Как по . нью ерк отличный город для путешествия...
2
Для сжигания 15 г водорода взяли 90 г кислорода. вычислите массу образовавшейся...
3
Собака различает полмиллиона запахов, а человек- всего 5000 запахов. во сколько...
3
begin
readln (n);
p:=n;
while p<> 0 do begin
k:=k+1;
p:=p div 10;
end;
writeln ('k=',k);
end.