Составьте программу, определяющую остаток от деления числа а на число в. составьте программу, заменяющую большее из двух данных чисел модулем суммы, а меньшее – модулем полуразности этих чисел.(pascal)

Alesja4788 Alesja4788    3   17.03.2019 09:00    3

Ответы
gotov2344433332 gotov2344433332  25.05.2020 18:30

1. program ostatok;

uses crt;

var a,b,ost:real;

begin

write('a= ');

readln(a);

write('b= );

readln(b);

ost:=a mod b;

write('ostatok ot delenia A na B raven ',ost);

readln;

end.

 

2. program modul;

uses crt;

var a,b,c,d: real;

begin

write('a= ');

readln(a);

write('b= );

readln(b);

c:=a-b;

if c>0 then

begin

a:=abs(a+b);

b:=abs((a-b)/2);

write('a= ',a,'b= ',b);

end

else

b:=abs(a+b);

a:=abs((b-a)/2);

write('a= ',a,'b= ',b);

end;

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика