Составьте программу нахождения в линейном массиве целых чисел из 10 элементов, заполненных случайным образом, произведение нечетных элементов.

anasstasissya anasstasissya    1   25.11.2020 13:26    1

Ответы
Nastia200704 Nastia200704  25.12.2020 13:27

program z1;

var a:array[1..10] of integer;

i,p:integer;

begin

p:=1;

randomize;

writeln('Массив: ');

for i:=1 to 10 do

begin

a[i]:=random(10);

write (a[i]:3);

if a[i] mod 2 <> 0 then p:=p*a[i]

end;

writeln;

write ('p = ',p)

end.

Объяснение:

р = 1, т.к. при умножении на 1 произведение не изменяется

Заполняем массив используя random

Выводим элемент

Если элемент нечётный, то считаем произведение

Вывод произведения

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика