Составьте программу нахождения наименьшего общего кратного (нок) двух чисел, используя формулу: а*в = нод(а*в)*нок(а, в). (по алгоритму евклида на паскале)

KirikRu KirikRu    1   20.05.2019 05:40    13

Ответы
лев234325 лев234325  13.06.2020 13:20
Var
    x, y, p: Integer;

begin
    Writeln('Введите два числа');
    Readln(x, y); {вводим два целых числа}
    p := x * y;
    
    repeat
        if x > y Then x := x Mod y
        Else y := y Mod x
    until (x = 0) Or (y = 0);
    {до тех пор, пока одно из чисел не станет равно нулю}
    
    Writeln('НОK=', p / (x + y)); {вывод НОД - без условного оператора, так как одно из чисел обязательно равно нулю}
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика