Составьте программу нахождения наименьшего натурального n-значного числа x (х> =10), равному утроенному произведению своих цифр. pascal

ilyaderkach98 ilyaderkach98    1   20.07.2019 11:00    3

Ответы
adikaeva1973 adikaeva1973  22.09.2020 20:47
Максимальное число, составленное из утроенного произведения цифр  будет 
9*3*N  -  не  может быть больше 54,  т.е.  
N может быть только 1 или 2.  По условию х>=10  ->  N=2  (N -порядок числа).
Поэтому искать нужно среди чисел от 11 до 54.  Решение - число 15.

var n,m: integer;
begin
  write('n = ');  readln(n);
  if n=2 then
  begin    m:=11;
    repeat
      if (m mod 10)*(m div 10)*3=m then
      begin
        writeln('число:  ',m);
        m:=55;
      end;
      m:=m+1;
    until m>54;
  end
  else  writeln('нет решения');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика