Составьте программу нахождения количества делителей числа n (значение n вводится с клавиатуры)

serdykivka serdykivka    1   09.08.2019 16:40    4

Ответы
GaLat666 GaLat666  20.08.2020 06:21
uses crt;
Var x, y, k:integer;
procedure delit;
begin  k:=0;  
writeln('Делители числа ', x, ':');  
for y:=1 to x do  if x mod y=0 then
begin
write( y, ' ');  
k:=k+1
end;  
writeln('Количество делителей числа ', x, ' равно ', k);
end;
begin clrscr;  
writeln ('Введите число: ');  
readln (x);  
delit;  
readln;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика