Составьте программу на языке Python с оператора while. Преобразуйте вес, заданный в пудах (в пределах 1-50 пудов), в килограммы. Формула преобразования 1пуд =16,2 кг. Вывести на экран только целый вес в килограммах

за правильный ответ поставлю и отмечу, как лучший ответ​


Составьте программу на языке Python с оператора while. Преобразуйте вес, заданный в пудах (в предела

Miha96555 Miha96555    3   11.03.2021 11:51    5

Ответы
ztv1978 ztv1978  10.04.2021 11:51

если с одной запятой в результате то:

import math

pyd = int(input('Введите количество пудов от 1 до 50: '))

kg = (pyd*16.2)

while pyd >=1 and pyd <=50:

   kg=round(kg,2)

   print(kg,'кг')

   break

else:

   print('Вы что-то ввели не верно')

Если целое с округление (16.2 = 16,  64.8 =65)

import math

pyd = int(input('Введите количество пудов от 1 до 50: '))

kg = (pyd*16.2)

while pyd >=1 and pyd <=50:

   kg=round(kg,0)

   print(kg,'кг')

   break

else:

   print('Вы что-то ввели не верно')

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика