Составьте программу на языке программирования Паскаль, в которой требуется выполнить следующие действия: • Пользователь задает с клавиатуры последовательность из n целых чисел (n также определяется пользователем). Найти среднее арифметическое чисел из этой последовательности.

chmy1998 chmy1998    1   19.06.2020 13:33    3

Ответы
saaafffina8902 saaafffina8902  15.10.2020 14:27

var N,x,S,i:integer;

   SR:real;

begin

 writeln ('кол-во чисел в последовательности N=');

 readln (N);

 S:=0;

 for i:=1 to N do

 begin

   read (x);

   S:=S+x;

 end;

 Sr:=S/N;

 Writeln('Sr=',Sr)

end.

Объяснение:

ПОКАЗАТЬ ОТВЕТЫ
egorcop egorcop  15.10.2020 14:27

--- PascalABC.NET 3.6.2 ---

begin

 var N := ReadInteger();

 var S := ReadSeqInteger(N);

 S.Average.Println;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика