Составьте программу на языке паскаль для решения квадратного уравнения (7х-1)^3/4-x^2(x+1,5) при х=4,12

sashaWinka sashaWinka    2   28.08.2019 23:40    1

Ответы
Smartfone Smartfone  06.10.2020 01:34
Var
a,b,c,x1,x2,d:real;
begin
write('Введите A='); readln(a);
write('Введите B='); readln(b);
write('Введите C='); readln(c);
D:=b*b-4*a*c;
if D<0 then begin
writeln('Нет корней');
end;
if D=0 then begin
writeln('x1=',-b/(2*a))
end;
if D>0 then begin
x1:=(-b-sqrt(d))/(2*a);
x2:=(-b+sqrt(d))/(2*a);
writeln('x1=',x1);
writeln('x2=',x2);
end;
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика