Составьте программу на языке C++,заменяющую меньшее из двух чисел модулем разности ,а большее-модулем произведения этих чисел.

Истар Истар    1   31.10.2020 15:24    5

Ответы
Polina4645 Polina4645  30.11.2020 15:25

#include <iostream>

#include <cmath>

using namespace std;

int main()  

{

 int first, second, temp;

 cin >> first >> second;

 if (first > second)

 {

   temp = first;

   first = abs(first * second);

   second = abs(temp - second);

 }

 else

 {

   temp = second;

   second = abs(second * first);

   first = abs(temp - first);

 }

 cout << first << " " << second;

}

Объяснение:

#include <iostream>  // Библиотека ввода - вывода

#include <cmath>  // Библиотека с математическими функциями

using namespace std;  // Пространство имен

int main()  

{

 int first, second, temp;  // Создание целочисленных переменных:

first - первое число, вводимое с клавиатуры;second - второе число, вводимое с клавиатуры;temp - переменная, для временного хранения одного из значений.

 cin >> first >> second;  // Вводим с клавиатуры первое и второе числа

 if (first > second)  // Если значение переменной first > значения переменной second

 {

   temp = first;  // Переменная временного хранения = значению переменной first

   first = abs(first * second);  // Значение переменной first (большей) = модулю произведения двух чисел

   second = abs(temp - second);  // Значение переменной second (меньшей) = модулю разности двух чисел

 }

 else  // Иначе

 {

   temp = second;  // Переменная временного хранения = значению переменной second

   second = abs(second * first);  // Значение переменной second (большей) = модулю произведения двух чисел

   first = abs(temp - first);  // Значение переменной first (меньшей) = модулю разности двух чисел

 }

 cout << first << " " << second;  // Выводим значения переменных first и second

}

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика