Составьте программу на Паскале
На вход программы поступает неизвестное количество натуральных чисел, ввод заканчивается нулём. Найти минимальное из введённых нечётных чисел

2006215 2006215    1   25.04.2020 21:14    2

Ответы
Uoywex Uoywex  13.10.2020 21:21

var a, min:integer;

begin

writeln('Введите числа (цифра 0 - выход из программы)');

readln(a);

min:= a;

while(a <> 0) do begin

 if (((a mod 2) = 1) and (min > a)) then

   min:= a;

readln(a);

end;

writeln('Минимальное нечетное число: ', min);

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика