Составьте программу на паскале.даны три различных вещественных числа,найти среднее из них.среднее число- это такое , которое больше наименьшего из данных чисел,но меньше наибольшего.

ммм298 ммм298    1   31.07.2019 12:50    1

Ответы
volkovaolga75 volkovaolga75  03.10.2020 18:35
//Pascal ABC.NET 3.1 сборка 1219

Var
 a,b,c:real;
begin
 read(a,b,c);
 if ((a>b) and (a<c)) or ((a<b) and (a>c)) then writeln(a);
 if ((b>a) and (b<c)) or ((b<a) and (b>c)) then writeln(b);
 if ((c>a) and (c<b)) or ((c<a) and (c>b)) then writeln(c);
end.

Пример ввода:
1.1
1.2
1.3
Пример вывода:
1.2
ПОКАЗАТЬ ОТВЕТЫ
Dancerebuclic2017 Dancerebuclic2017  03.10.2020 18:35
// PascalABC.NET 3.1, сборка 1256 от 21.06.2016
begin
  var a,b,c:real;
  Write('Введите три числа: '); Read(a,b,c);
  Print('Среднее из чисел:');
  Seq(a,b,c).Sorted.Skip(1).Take(1).Println;
end.

Тестовое решение
Введите три числа: 5.3 2.8 10
Среднее из чисел: 5.3
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика