Составьте программу, котораясоставьте программу, которая заполняет массив а[1,,10 ] случайными числами в диапазоне от 0 до 10 , затем первый элемент меняет местами с максимальным элементом. выведите на экран исходный и полученный массивы.

Duna383292928282 Duna383292928282    2   28.05.2019 15:20    75

Ответы
к2а2т2я к2а2т2я  26.06.2020 08:26
uses crt;
const N=10;
var a:array [1..N] of integer;
    x,pos,max:integer;
begin
     randomize;
     for x:=1 to N do
     begin
         a[x]:=random(11);
         writeln('a[',x,']:',a[x]);
     end;
     max:=1;
     for x:=1 to N do
          if a[x]>a[max] then max:=x;
     pos:=a[1];
     a[1]:=a[max];
     a[max]:=pos;
     writeln;
     for x:=1 to N do
         writeln('a[',x,']:',a[x]);
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика