Составьте программу которая заполняет массив b случайными целыми числами в диапазоне от 1 до 10 и находиь произведение элементов с нечетными значениями и количество элементов с четными значениями

Умник00Семь Умник00Семь    2   15.08.2019 00:40    3

Ответы
zhenya214 zhenya214  04.10.2020 19:55
// PascalABC.NET 3.2, сборка 1356 от 04.12.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var a:=ArrRandom(8,1,10); a.Println;
  Writeln('Произведение нечетных элементов ',
    a.Where(x->x.IsOdd).Aggregate(1,(x,y)->x*y));
  Writeln('Количество четных элементов ',
    a.Where(x->x.IsEven).Count)
end.

Пример
9 10 10 5 8 3 5 2
Произведение нечетных элементов 675
Количество четных элементов 4
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика