Составьте программу которая заполняет массив а 1..8 случайными целыми числами в диапазоне от 1 до 10 и выводит на экран количество элементов с четными значениями и сумму элементов массива с нечетными значениями

yurafenchishin yurafenchishin    3   03.10.2019 12:01    4

Ответы
supercrud supercrud  09.10.2020 14:05

program massive;

const n=8;

var a:array[1..n]of integer;

sum,k,i:integer;

begin

sum:=0;

k:=0;

//заполнение массива

for i:=1 to n do

begin

a[i]:=random(10);

end;

if a[i] mod 2=0 then inc(k)

esle sum:=sum+a[i];

writeln('кол-во четных элементов =', k);

writeln('Сумма нечетных элементов =',sum);

readln;

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика