Составьте программу, которая выводит все делители натурального числа n (в паскале)

sdadaev sdadaev    2   20.08.2019 10:30    1

Ответы
NadushaLove12 NadushaLove12  26.08.2020 07:26
Var n,i:integer;
begin
write('n = ');
readln(n);
writeln('Делители:');
for i:=1 to n div 2 do
 if n mod i = 0 then write(i,' ');
writeln(n);
end.

Пример:
n = 24
Делители:
1 2 3 4 6 8 12 24
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика