tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу которая
Составьте программу которая выводит на экран из всех трёхзначных чисел, только те у которых квадрат первой цифры равен сумме двух остальных.
Юрашевич101
1 19.07.2019 10:10
6
Ответы
archakova65
03.10.2020 07:49
Var
i: integer;
begin
for i:=100 to 999 do
if (sqr(i div 100) = i mod 10 + i div 10 mod 10) then
writeln(i);
end.
ПОКАЗАТЬ ОТВЕТЫ
Викуська2531
03.10.2020 07:49
// PascalABC.NET 3.1, сборка 1172 от 19.02.2016
begin
for var i:=100 to 999 do begin
var d1:=i div 100;
var d2:=(i div 10) mod 10;
var d3:=i mod 10;
if sqr(d1)=d2+d3 then Print(i)
end;
Println
end.
Тестовое решение:
101 110 204 213 222 231 240 309 318 327 336 345 354 363 372 381 390 479 488 497
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
Яна775975
29.05.2019 05:30
Всем ! ) нужно составить программу в excel или mathcad или vba. программа должны выводить в массив перечень чисел, кратных 2,3,5. диапазон вывода чисел - от нуля, а верхняя...
жсдрю
29.05.2019 05:30
Какие из перечисленных объектов являются элементами компьютерного интерфейса? -окна; -экранные кнопки; -рабочий стол; -панель ; -меню....
виктория907
29.05.2019 05:30
Дано информационное сообщение объёмом 3 кбайта. сколько в нем символов, если размеры алфавита, с которого оно было составлено, равен 16?...
Danil0220
29.05.2019 05:30
Дано натуральное число n. переставить первую и последнюю цифру числа n. пример: n: =123456 s=623451...
Helokiti2343
29.05.2019 05:30
Впаскале нужна программа,которая поменят два элемента первый и последний заранее ) от 1 до 20 9 класс...
Polino4ka171
27.05.2019 08:20
Составить алгоритм нахождения наименьшего из трех значений....
Gjvjub000
28.05.2021 11:09
Ребята ! Буду очень благодарна! 1.С каких имён началась информатика? Расскажите о вкладе в данную науку этих людей. 2.Какое важное событие произошло в 1984 году в сфере IT-технологий?...
АляМиткалова
22.09.2021 10:50
Выберете правильный ответ me with my homework? Will you helps 1. You will help 2. Will help you 3. Will you help...
oll5
22.09.2021 10:36
1. В кабинете информатики имеется 5 компьютеров и принтер. Для обмена информацией между компьютерами и для возможности совместного использования принтера необходимо соединить...
XTreams
28.10.2020 13:39
стан захищеності потреб людини, суспільства та держави в інформації не залежно від внутрішніх і зовнішніх загроз називають ...
Популярные вопросы
ответы на во на стр 229 по литературе 7 класс меркин 2 часть чтоб можно...
2
Посчитайте, сколько процентов (%) энергии достанется ястребам, если энергию,...
2
Воздух,пахнущий туманом,свежестью утра,врывается в комнату. Как подчеркнуть...
2
Ведущий мировой международный правительственный форум научно-технического...
1
1. Тестовые задания открытой формы1.1. Впервые казахские правители вступили...
1
История Украины 9 клас, тесты ст...
2
Соб…рательный образ, расст…лю, расст…лать, выж…гать по дереву, обд…рать...
3
3 x−8 (2 x+5 )+(2 x−3 )=−10;...
3
1) Заряды 5нКл и 8нКл находятся на расстоянии 5мм. Какая сила будет действовать...
1
Начертите oбраз oтрезка АВ при пoвoрoте плoскoсти вoкруг тoчки O на 90°...
1
i: integer;
begin
for i:=100 to 999 do
if (sqr(i div 100) = i mod 10 + i div 10 mod 10) then
writeln(i);
end.
begin
for var i:=100 to 999 do begin
var d1:=i div 100;
var d2:=(i div 10) mod 10;
var d3:=i mod 10;
if sqr(d1)=d2+d3 then Print(i)
end;
Println
end.
Тестовое решение:
101 110 204 213 222 231 240 309 318 327 336 345 354 363 372 381 390 479 488 497