tutotveti.ru
Предметы
Биология
Українська мова
Музыка
Французский язык
Физика
МХК
Обществознание
Психология
ОБЖ
Право
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Английский язык
Русский язык
Окружающий мир
Алгебра
История
Другие предметы
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу которая
Составьте программу которая вычисляет сумму натуральных чисел на отрезке ( 5, 10 ) с оператора while
Leha9202
3 24.06.2019 15:40
5
Ответы
anastasijakokos
02.10.2020 10:23
Var n, o: integer;
begin
n:=5;
while (n<>11) do
begin
o:=o+n;
n:=n+1
end;
writeln(o)
end.
ПОКАЗАТЬ ОТВЕТЫ
KimSuho01
02.10.2020 10:23
#include <conio.h>
#include <iostream>
#include <locale.h>
using namespace std;
int main()
{
setlocale(0,"");
int x_min,x_max;
int Sum;
cout<<"Введите начало отрезка\n";
cin>>x_min;
cout<<"Введите конец отрезка\n";
cin>>x_max;
int temp=x_min;
if(x_min>x_max) //проверяем что бы минимальный элемент не был больше максимального
{
int temp;//буфер
temp=x_min;
x_min=x_max;
x_max=temp;
}
while(x_min<=x_max)
{
Sum+=x_min;
++x_min;
}
cout<<"Сумма натуральных эментов на отрезке ("<<temp<<","<<x_max<<") = "<<Sum<<endl;
return 0;
}
Программа вычисляет отрезок любого элемента и делает проверку на правильность ввода
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
shantropa33
14.02.2020 16:06
Вычислить значение заданного выражения используя процедуры и функции. Паскаль2 и 4 задание ...
Nata10445love
14.02.2020 15:56
Запиши верный ответ. 50176 байтов = Кбайт...
руслан7661
14.02.2020 15:52
Какой из перечисленных не является описания алгоритма? 1)математический 2)табличный 3)словесный 4)графический...
zaharsteam
10.08.2019 06:00
Расставьте в правильном порядке этапы решения на компьютере 1) формализация 2) алгоритмизация 3) постановка 4) отладка и тестирование 5) программирование...
жуля7
18.05.2021 19:56
Скласти Програму на мові Pascal...
Ятот
25.07.2019 03:00
Даны координаты точки на плоскости. известно, что окружность радиусом р центром совпадает с началом координат. определить, лежит ли данная точка на окружности или же вне её....
RU2017
18.06.2019 23:50
Сформировать массив из 20 элементов.вывести на экран.положительные элементы умножить на 8.отрицательные разделить на 3.вывести на экран преобразованный массив. , нужно...
olesmekhedova
18.06.2019 23:50
Назовите современные носители информации...
хеллокиттичка
22.01.2022 23:54
$ 4. ВОСТОЧНЫЕ СЛАВЯНЕ И ИХ СОСЕДИ Задание 1. Найдите в учебнике (с. 28–29) названия сла вянских союзов племён. Заполните таблицу. в таблице союз племён, территории его проживания...
nikdelordp08m0z
22.01.2022 23:54
Listen again and write true or false. Correct the false sentences. 1 Someone from the school is going to meet the author at the airport 2 Mel will be working at 3 pm on the Sunday...
Популярные вопросы
Написать эссе(сочинение) от 1 лица петра 1 его детсво и юность заранее...
1
Почему плёнка бензина на воде окрашивается в разные цвета?...
3
Вящике 4 белых шаров 5 черных и 6 красных шары вынимают в темноте и на ощупь они...
2
Нужно напиать мини сочинение на тему роль предпринимательства в...
3
Вмагазин 9 ящиков яблок по 20 кг в каждом,а груш в 3 раза меньше.на сколько больше...
1
Что надо делать чтобы сохранить растения занесённые в красную книгу?...
3
Замена слово подкрадываться из 4 предложения...
1
Complete the sentences with the correct adverb of time. 1) i saw him . 2) it is...
3
Найдите решить скорость катера против течения реки равна17,8 скоростькатерп-19,4км/что....
3
Напишите уменьшонный септаккорд на 7 ступени в си бемоль миноре нотами...
3
begin
n:=5;
while (n<>11) do
begin
o:=o+n;
n:=n+1
end;
writeln(o)
end.
#include <iostream>
#include <locale.h>
using namespace std;
int main()
{
setlocale(0,"");
int x_min,x_max;
int Sum;
cout<<"Введите начало отрезка\n";
cin>>x_min;
cout<<"Введите конец отрезка\n";
cin>>x_max;
int temp=x_min;
if(x_min>x_max) //проверяем что бы минимальный элемент не был больше максимального
{
int temp;//буфер
temp=x_min;
x_min=x_max;
x_max=temp;
}
while(x_min<=x_max)
{
Sum+=x_min;
++x_min;
}
cout<<"Сумма натуральных эментов на отрезке ("<<temp<<","<<x_max<<") = "<<Sum<<endl;
return 0;
}
Программа вычисляет отрезок любого элемента и делает проверку на правильность ввода