Составьте программу, которая вычисляет оптимальный вес, сравнивает его с реальным и выдаёт рекомендацию о необходимости поправиться или похудеть (с указанием, на сколько кг нужно поправиться или похудеть). оптимальный вес вычисляется по формуле: рост (в см) – 100.

Nastyavoyko Nastyavoyko    1   30.07.2019 12:30    4

Ответы
юла115 юла115  03.10.2020 17:27
Программа ниже.
Код:
var
 rost, ves, opt: integer;
begin
  write('Введите рост: ');
 readln(rost);
 opt := rost - 100;
 write('Введите вес: ');
 readln(ves);
 if ves < opt then
   writeln('Вам нужно поправиться на ', opt - ves, ' кг.');
 if ves > opt then
   writeln('Вам нужно похудеть на ', ves - opt, ' кг.');
 if ves = opt then
   writeln('Ваш вес оптимальный');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика