Составьте программу, которая удаляет лишние пробелы в строке s, оставляя по одному пробелу между словами. строка s, состоящая из слов, разделенных пробелами, вводится с клавиатуры.

tatarincevai tatarincevai    1   14.08.2019 05:50    4

Ответы
mstella2003 mstella2003  14.08.2020 13:55
// PascalABC.NET 3.2, сборка 1353 от 27.11.2016
// Внимание! Если программа не работает, обновите версию!

begin
  var s:=ReadlnString('>').ToWords.JoinIntoString;
  s.Println;
end.

Пример
>     А   роза   упала на     лапу    Азора
А роза упала на лапу Азора
ПОКАЗАТЬ ОТВЕТЫ
timurev timurev  14.08.2020 13:55
Uses System;
uses System.Linq;var s: array of string;
a: string;
i, x: integer;begin
readln(a);
s := a.Split();
for i := 0 to s.Length - 1 do
  if (s[i].Length <> 0) then
    write(s[i] + ' ');
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика