Составьте программу которая считывает три числа введенные и выводит наибольшее из них.

raymondbaby raymondbaby    2   28.05.2019 09:12    5

Ответы
Илья11345 Илья11345  25.06.2020 20:07

string chisla = "";

           int max = 0;

           Console.Write("Введите три числа через пробел: ");

           chisla = Console.ReadLine();

           int[] mas = new int[3];

           for (int i = 0; i < mas.Length; i++)

           {

               mas[i] = Convert.ToInt32(chisla.Split(' ')[i]);

           }

           for (int i = 0; i < mas.Length; i++)

           {

               if (mas[i] > max)

               {

                   max = mas[i];

               }

           }

           Console.WriteLine();

           Console.Write("Наибольшее число = {0}", max);

           

           Console.ReadKey();

Объяснение:

Язык не указан, написано на C#.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика