Составьте программу, которая позволяет заменить в строке слово мама на слово папа

D2a0h0a9 D2a0h0a9    3   15.08.2019 11:50    1

Ответы
akimfugenko akimfugenko  02.08.2020 16:53
Var //Объявляем переменные
i:integer;
s:string;
begin // Начало работы блока
readln(s); // В переменную S записываем введенную строку
i := Pos('мама', s);  // В переменную i записываем количество символов до данного слова
if i > 0 then //Если количество символов больше нуля тогда
 begin  
Delete(s, i, 4);  // Удаляем из веденной строки (Переменная S), слово мама, содержащие 4 символа 
Insert('папа', s, i);  // Заменяем словом Папа
end; //Конец
writeln(s); //Выводим на экран полученный текст
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика