tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу которая
Составьте программу которая позволяет закодировать строку путем замены всех звонких согласных на соответствующие глухие, а глухих на звонкие
EgorKornev665
2 27.05.2019 22:50
8
Ответы
Sukhareva1509
25.06.2020 07:29
const
s: array [1..6] of char= ('б','в','г','д','ж','з');
d: array [1..6] of char= ('п','ф','к','т','ш','с');
var
c: string;
i,j: integer;
begin
readln(c);
for i:= 1 to length(c) do
for j:= 1 to 6 do
if d[j]=c[i] then c[i]:= s[j]
else
if s[j]=c[i] then c[i]:= d[j];
writeln(c)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
danilarostov2
19.03.2020 19:21
Очень сильно Код писать на Python3 или C++....
ariana76
19.03.2020 19:20
Операторы ввода и выводаКарточка No 11...
Diagramma1
19.03.2020 19:17
Help (первое задание не смотрите) ...
ghbdtnzujdyjfns
28.03.2019 16:00
Вчем заключается преимущества использования ссылок в формулах? -...
GayaneshkaBrainly
28.03.2019 16:30
Даны 5 чисел, найти сумму и кол-во положительных и произведение и кол-во отрицательных. блок схема...
BaVeRSB
28.03.2019 16:40
Заполните массив случайными числами, все чётные увеличить на 1 а нечётные уменьшить на 1 в си...
neket678885
28.03.2019 16:40
Существительные признаки слов агроном ,брейк ,видео клип ,дюйп жалюзи , ,мультипликация пастила ,универсальный ,кто может по быстрее , а то в школу апазаю...
ustishca
28.03.2019 16:40
Сколько секунд потребуется модему, сообщения со скоростью 32000 бит/с, чтобы передать 16-цветное растровое изображение размером 800х600 пикселей, при условии, что в каждом байте...
Alinalina080206
28.03.2019 16:40
Сколько информации содержится в сообщении объемом 2 в 21 степени бит? (ответ дайте в мб)...
sashachernov1
28.03.2019 16:50
Дано целое число. если оно является положительным, то прибавить к нему 1; в противном случае не изменятьего. вывести полученное число....
Популярные вопросы
Символіка до п єси Ляльковий дім ...
3
4. Состваьте 2 простых вопроса по тексту....
3
Плюси і мінуси Катерини з повісті Катерина в цитатах ...
1
Обчисліть кількість речовини води , що утворюються в наслідок нагрівання ферум...
2
ста, если можно с решением...
2
СОЧ ПО ИСТОРИИ КАЗАХСТАНА...
1
Төлеген Айбергеновтың « Сағыныш » өлеңінен алынған үзіндідегі бос орындарды...
1
Люди очень Если можно то полностью ....
3
Определите лексическое значение слов. академия ансамбль величина гармония грандиозность...
3
Вопросы по произведению ,,Детство Тёмы,, 8 глава ,,Иванов,, 1) Каких авторов...
3
s: array [1..6] of char= ('б','в','г','д','ж','з');
d: array [1..6] of char= ('п','ф','к','т','ш','с');
var
c: string;
i,j: integer;
begin
readln(c);
for i:= 1 to length(c) do
for j:= 1 to 6 do
if d[j]=c[i] then c[i]:= s[j]
else
if s[j]=c[i] then c[i]:= d[j];
writeln(c)
end.