Составьте программу, которая по трем введенным вами числам определит является ли треугольник прямоугольным?

Kukushka2281337 Kukushka2281337    1   16.04.2019 17:35    1

Ответы
Ghanali Ghanali  29.05.2020 16:23

program raf105;

var a,b,c:integer;

abc: boolean;

begin

write('Введите длины трёх сторон через пробел: ');

readln(a,b,c);

if (a>b) and (a>c)

 then if a**2=b**2+c**2

   then abc:=true;

if (b>a) and (b>c)

 then if b**2=a**2+c**2

   then abc:=true;

if (c>b) and (c>a)

 then if c**2=b**2+a**2

   then abc:=true;

if abc=true

 then writeln('Это прямоугольный треугольник')

 else writeln('Это не прямоугольный треугольник')

end.

Программа написана на языке PascalABC.NET

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика