Составьте программу, которая определяет, является ли данное натуральное число простым, и выводит на экран соответствующее сообщение: «да» либо «нет».

Teddy62711 Teddy62711    3   01.03.2019 07:50    16

Ответы
Arra1234566 Arra1234566  06.06.2020 21:21

program xxx;

var k, d, n : integer;

      pr : boolean;

begin

  writeln('Введите число k=');

  readln(k);

  d:=2;

  n:= k div 2;

  pr:=false;

  while (d<=n) and not(pr) do

     if k mod d = o then pr:=true else d:=d+1;

  if pr then writeln (k, '- нет, число не простое') else writeln (k, ' да,число простое');

   readln

end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика