Составьте программу,которая определяет,сколько слагаемых должно быть в сумме 1+2+3+ сумма оказалась: а)больше 20; б)больше заданного числа n;

Дарья290705 Дарья290705    2   14.03.2019 07:00    4

Ответы
yulechkastrelkp0aiwm yulechkastrelkp0aiwm  25.05.2020 06:43

program ddd;
var i,n,s,k:integer;
begin
write('Введите n: ');
readln(n);
s:=0; k:=0;i:=1;
while s<=n do
begin
s:=s+i;
writeln(i);
inc(i);
inc(k);
end;
writeln('Необходимо ',k,' слагаемых; сумма равна ',s );
end.

ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика