tutotveti.ru
Предметы
Биология
Физика
Українська мова
Музыка
Французский язык
Обществознание
МХК
Право
ОБЖ
Психология
Беларуская мова
Литература
Химия
Українська література
Экономика
Немецкий язык
География
Информатика
Қазақ тiлi
Геометрия
Русский язык
Английский язык
Окружающий мир
Алгебра
Другие предметы
История
Видео-ответы
ПОИСК
Войти
Регистрация
Информатика
Составьте программу которая находит
Составьте программу которая находит сумму цифр трех значного числа на pascalabc
fffff131
1 17.09.2019 20:20
2
Ответы
максим1718
10.09.2020 10:48
Program n1;
var a: integer;
begin
readln(a);
a:=abs(a);
write((a div 100)+ (a mod 10)+ (a mod 100 div 10));
end.
ПОКАЗАТЬ ОТВЕТЫ
Evelina0889
10.09.2020 10:48
Var
i,n,s: Integer;
begin
write('Введите трехзначное число ');
read(n);
i:=0;
while (n<>0) Do
begin
s :=n Mod 10;
i:=i+s;
n:= n Div 10;
end;
writeLn('Сумма цифр : ',i)
end.
ПОКАЗАТЬ ОТВЕТЫ
Другие вопросы по теме Информатика
коаладоби
02.11.2020 01:34
Здравствуйте. требуется вычислить прикреплённые примеры....
Aleksandr31821
02.11.2020 01:37
Дана таблица 14*6. Составить подпрограмму подсчета количества отрицательных элементов заданной строки. Обращаясь к подпрограмме вычислить количество отрицательных...
КоТоФеЙкА03
02.11.2020 01:37
Чи можна змінній передати значення окремого елемента масиву? такні залежить від мови програмуваннязалежить від компілятора...
rainbiwcat750KO
02.11.2020 01:38
Треба 2 і 3 задача, будь ласка дуже треба❤️❤️❤️...
AZIMJON11
02.11.2020 01:41
Какое условие следует использовать для вычисления Y по формулам: Y=X+15, при X 0; Y=X-15, при X 0 then Y:=X+15 else Y:=X-15; if X 0 then Y:=X-15 else Y:=X+15; ....
ch32
02.11.2020 01:41
Подскажите Что будет выведено на экран после выполнения фрагмента программы: M := 5; if m 5 then Y := 5 + m else Y := 100 -m writeln (Y);...
ulpashkova
02.11.2020 01:41
Дана таблица 14*6. Составить подпрограмму подсчета количества отрицательных элементов заданной строки. Обращаясь к подпрограмме вычислить количество отрицательных...
Marattadjibov73
02.11.2020 01:41
Чи можна змінній передати значення окремого елемента масиву? нізалежить від мови програмуваннятакзалежить від компілятора...
Moonlight06
14.03.2019 18:40
Для чего нужны клавиши esc enter shift caps lock alt insert home end page up page down num lock ?...
даданет
14.03.2019 18:50
Сколько единиц содержится в двоичной записи десятичного числа 124...
Популярные вопросы
Из данных 36, 5005, 700, 936, 387, 20014, 4503, 280 выбери те...
1
Решите уравнения: а) - 8( 11 – 2а) + 40 = 3(5а – 4); б) 7(-3(m...
1
1. -(0,4)2: (1,4-1 целая 3/7) решить пример по действиям. 2.сравните...
3
Мешке 3 красных 3 синий шарики наугад достали 3 шарика мешке...
1
Почему кирибеевич так поступает с алёной дмитриевной...
2
Напишите небольшой рассказ о каком-нибудь животном аляски, :...
3
По возрастанию галактика, солнечная система, вселенная, земля...
1
Можно ли предохранить порцию мороженого от быстрого таяния если...
2
Прочитайте. продолжите каждое простое предложение, чтобы получилось...
1
Найдите площадь круга, если длина его окружности равна a) 314...
2
var a: integer;
begin
readln(a);
a:=abs(a);
write((a div 100)+ (a mod 10)+ (a mod 100 div 10));
end.
i,n,s: Integer;
begin
write('Введите трехзначное число ');
read(n);
i:=0;
while (n<>0) Do
begin
s :=n Mod 10;
i:=i+s;
n:= n Div 10;
end;
writeLn('Сумма цифр : ',i)
end.